Tuesday, April 08, 2008

Cisco ADSL WAN card



The single-port ADSL WICs, which fit into any of the WIC, VIC/WIC, HWIC slots on the Cisco 1700/1800/2600/2800/3700/3800 series modular access routers.

ADSL card features:

• One RJ-11 ADSL interface
• Supports ADSL over POTS with Annex A ITU 992.1 (G.dmt)
• Complies with ANSI T1.413 issue 2
• Supports ATM AAL5
• Supports ATM Class of Service features CBR, VBR-nrt, VBR-rt, UBR
• Supports IP QoS
• Supports up to 23 virtual circuits on WIC
• Interoperates with third party and Cisco DSLAMs

Software Support

The ADSL feature is supported in the IP/ADSL Image ("y7" image) for the Cisco 1700 Series. Cisco 2600/3600/3700 series routers require a PLUS IOS image for ADSL if using 12.2T. From 12.3 Mainline and beyond ADSL WIC support is available in the "IP Base" feature set. Some QoS features require an advanced image (IP PLUS, IP VOICE, or above) for Cisco 1700/2600/3600/3700 series router support. The ADSL WICs are supported on the "IP Base" feature set for the Cisco 1800/2800/3800 ISRs. The default IOS image for the Cisco 1841 ADSL bundles is the Cisco IOS IP Broadband image. In addition to all the features of the "IP Base" image, the IP Broadband image also has the Service Assurance Agent (SAA) features. The default IOS image for the Cisco 2800 series ADSL bundles is the Cisco IOS SP Services image.

The ADSL over POTS WIC (WIC-1ADSL), is available on the Cisco IOS 12.3 Mainline for the Cisco 1700/2600/ 3600/3700 series routers. This WIC is supported on the 1800/2800 series ISRs starting with the Cisco IOS 12.3(8)T Release, and on the 3800 series ISRs starting with the Cisco IOS 12.3(11)T Release.

Source from www.cisco.com

Monday, March 03, 2008

Multilink PPP for DDR and ISDN

TEST_MLPPP#sh run
Building configuration...

Current configuration : 4959 bytes
!
version 12.2
!
hostname TEST_MLPPP
!
enable password 7 13061E010803
!
ip subnet-zero
!
ip cef
no ip domain lookup
!
isdn switch-type primary-net5
!
!
controller E1 6/0 "1st LL"
channel-group 0 timeslots 1-30
!
controller E1 6/1 "2nd LL"
channel-group 0 timeslots 1-30
!
controller E1 6/2 "3rd LL"
channel-group 0 timeslots 1-30
!
controller E1 6/3
!
controller E1 6/4
!
controller E1 6/5 "1st ISDN PRI"
pri-group timeslots 1-30
!
controller E1 6/6 "2nd ISDN PRI"
pri-group timeslots 1-30
!
controller E1 6/7 "3rd ISDN PRI"
pri-group timeslots 1-30
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Multilink1 "Main interface represent the 3 LLs"
ip address 60.140.10.126 255.255.255.252
no ip redirects
no ip proxy-arp
backup interface Dialer2 "ISDN backup with 3xPRIs"
no cdp enable
ppp multilink
ppp multilink links minimum 3 mandatory
multilink load-threshold 1 outbound
multilink-group 1

!
interface FastEthernet0/0
description *** Connection to CE LAN ***
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
!
interface Serial6/0:0 "1st LL"
ip address 60.140.10.34 255.255.255.252
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial6/1:0 "2nd LL"
ip address 60.140.7.254 255.255.255.252
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial6/2:0 "3rd LL"
ip address 60.140.10.38 255.255.255.252
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1

!
interface Serial6/5:15 "1st ISDN PRI"
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type primary-net5
ppp multilink
!
interface Serial6/6:15 "2nd ISDN PRI"
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type primary-net5
ppp multilink
!
interface Serial6/7:15 "3rd ISDN PRI"
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type primary-net5
ppp multilink

!
!
interface Dialer2 "Main interface represent the 3 ISDN PRIs"
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 600
dialer string 22220000
dialer load-threshold 1 outbound
dialer-group 1
no fair-queue
ppp chap hostname abc@abc.com
ppp chap password 7 070C31
ppp multilink links minimum 90 mandatory

!
!
ip classless
ip route 0.0.0.0 0.0.0.0 60.140.10.125
ip route 0.0.0.0 0.0.0.0 Dialer2 230

no ip http server
!
!
!
dialer-list 1 protocol ip permit
!
!
!
end

Monday, January 07, 2008

ADSL over Ethernet (Modem bridge and Router dial)

* ADSL over Ethernet. The ADSL modem will be acting as bridge, and the router CE will make a call via its Ethernet port. Have a try !!!!

RouterX#sh run
Building configuration...

Current configuration : 1480 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterX
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$OGqn$WnmL8LrQMH6gRxNzTiqTk1
enable password cisco
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
vpdn enable
vpdn ip udp ignore checksum
!
vpdn-group 1
request-dialin
protocol pppoe

!
!
no ftp-server write-enable
!
!
!
!
!
no crypto isakmp ccm
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1

!
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname abc@test.com.my
ppp chap password 0 abc
ppp pap sent-username abc@test.com.my password 0 abc

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
access-list 1 permit any
dialer-list 1 protocol ip permit

!
!
control-plane
!
!
!
!
end

Sunday, January 06, 2008

ADSL backup


version 12.3
!
hostname ADSL BACKUP
!
ip subnet-zero
!
vpdn enable
!
vpdn-group pppoe
!
interface FastEthernet0/0
description LAN NETWORK
ip address 172.16.10.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Serial0/0/0
description WAN – PRIMARY LINK
ip address 58.139.38.58 255.255.255.252
encapsulation ppp
clockrate 2000000
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/1/0.1 point-to-point
pvc 0/40
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface Dialer1
description WAN – ADSL BACKUP LINK
ip address negotiated
encapsulation ppp
dialer pool 1
dialer persistent
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username backup1@dsl password dsltest
ppp multilink

!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 0.0.0.0 0.0.0.0 Dialer1 230
ip nat inside source list 1 interface Dialer1 overload
!
!
end